Handler “PageHandlerFactory-Integrated” has a bad module “ManagedPipelineHandler” in its module list

Windows Server 2008 üzerinde .Net Framework 4.0 kurulumunu yaptıktan sonra web sitelerimi ASP.NET 4.0 ile çalıştırmak istediğimde bu hata ile karşılaştım. Hata, IIS’ in sunucudaki en güncel sürüm ile uyum sağlayamamasından kaynaklanıyor. Aşağıdaki adımları izleyerek sunucunuzdaki en güncel framework’ ü yapılandırarak hatayı giderebilirsiniz.

  • Öncelikle başlar > çalıştır (start>run) ‘ a girerek cmd yazıyor ve enter tuşuna basıyoruz
  • Açılan pencere de cd “C:\Windows\Microsoft.NET\Framework\” komutunu giriyoruz. (64bit ise Framework64 yazmanız gerekli)
  • dir komutunu kullanarak tüm dizinleri listeliyoruz.
  • v4.0 olan dizine cd v4.0… şeklinde dizin ismini yazarak giriyoruz. (veya güncel sürüm ne ise…)
  • aspnet_regiis.exe -i komutunu girerek işlemleri tamamlıyoruz, IIS’ i yeniden yapılandıracaktır.

Kısacası yaptığımız işlem sunucudaki güncel framework dizine erişim aspnet_regiis.exe -i komutunu çalıştırıyoruz, bu sayede IIS güncel framework sürümümüz ile uyum sağlayayacak şekilde yeniden yapılandırılıyor.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir